题目

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

1
2
3
4
5
6
7
8
9
6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

1
2
3
4
5
6
LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题解

思路

  • 给定一棵树和两个节点
  • 让你求这两个节点的最近的公共上级
  • 我们要抓住核心——
  • 就是在中序中,永远是根左右这样的顺序排列的。
  • 如果假设两个节点的下标是a,b
  • 如果中序遍历中,一棵树或者说子树的根的下标,正好在a与b之间,那么这个根就是公共上级
  • 如果ab都在根的左边,那么进入左子树。
  • 如果ab都在根右边,那么进入右子树。
  • 还是使用老方法找左子树右子树,即以中序为核心,以前序遍历找根划分左右子树

数据结构

  • _in 是中序遍历的结果
  • pre 是前序遍历的结果
  • pos_in 是一个哈希表,带把每个节点的所在中序位置。比如中序遍历是[1,2,99],那么pos_in[99] = 2代表元素99在第二个位置。也可以不设这个哈希表,用集合存储所有的元素来判断给定节点在不在树里,然后第一次进入lca()函数使用.index()函数找到a,b的下标

算法

  • 重点是理解lca()函数。
    • lca() 函数会接受一棵树——其实就是以中序为标准,给定左边界和右边界,组成的一棵树(也是子树)
    • lca() 函数会接受前序遍历中的一个下标,这个下标对应着的前序遍历中的根。也就是函数接受到的树的根的值。
    • 同时接受a,b即要查询的两个数在中序中的下标。
    • 找到在中序中,根的下标。
    • 如果a和b都在其左侧,说明我们要去左子树找
    • 如果a和b都在其右侧,说明我们要去右子树找(注意这时候的前序根下标的更新)
    • 如果其等于a了,说明a是祖先
    • 如果其等于b了,说明b是祖先
    • 如果其在a和b之间,那么它就是祖先。

代码

  • 最后两个测试点又没有按照格式给出,因此也放了C++的题解。

Python

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
num_test, num_nodes = list(map(int, input().split()))
_in = list(map(int, input().split()))
pos_in = {i: j for i, j in zip(_in, range(num_nodes))}
pre = list(map(int, input().split()))


def lca(in_L, in_R, pre_root, a, b):
if in_L > in_R:
return 0
in_root = pos_in[pre[pre_root]]
if a < in_root and b < in_root:
lca(in_L, in_root - 1, pre_root + 1, a, b)
elif (a < in_root < b) or (a > in_root > b):
print("LCA of %d and %d is %d." % (_in[a], _in[b], _in[in_root]))
elif a > in_root and b > in_root:
lca(in_root + 1, in_R, pre_root + 1 + (in_root - in_L), a, b)
elif a == in_root:
print("%d is an ancestor of %d." % (_in[a], _in[b]))
elif b == in_root:
print("%d is an ancestor of %d." % (_in[b], _in[a]))


for _ in range(num_test):
a, b = list(map(int, input().split()))
if a not in pos_in and b not in pos_in:
print("ERROR: %d and %d are not found." % (a, b))
elif a not in pos_in:
print("ERROR: %d is not found." % a)
elif b not in pos_in:
print("ERROR: %d is not found." % b)
else:
lca(0, num_nodes - 1, 0, pos_in[a], pos_in[b])

C++

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
#include <bits/stdc++.h>

using namespace std;

unordered_map<int,int> pos_in;

int lca(int in[],int pre[], int in_L, int in_R, int pre_root, int a, int b) {
if (in_L > in_R)
return 0;
int in_root = pos_in[pre[pre_root]];
if (a < in_root and b < in_root)
lca(in,pre,in_L, in_root - 1, pre_root + 1, a, b);
else if ((a < in_root and in_root < b) or (a > in_root and in_root > b))
printf("LCA of %d and %d is %d.\n" ,in[a], in[b], in[in_root]);
else if (a > in_root and b > in_root)
lca(in,pre,in_root + 1, in_R, pre_root + 1 + (in_root - in_L), a, b);
else if(a == in_root)
printf("%d is an ancestor of %d.\n" ,in[a], in[b]);
else if (b == in_root)
printf("%d is an ancestor of %d.\n" ,in[b], in[a]);
}

int main() {
int num_test,num_nodes;
cin>>num_test>>num_nodes;
int in[num_nodes];

for (int i = 0;i<num_nodes;i++){
cin>>in[i];
pos_in[in[i]] = i;
}
int pre[num_nodes];
for (int i = 0;i<num_nodes;i++)
cin>>pre[i];

for (int i = 0;i<num_test;++i){
int a,b;
cin>>a>>b;
if (pos_in.count(a) == 0 && pos_in.count(b) == 0)
printf("ERROR: %d and %d are not found.\n" ,a, b);
else if (pos_in.count(a) == 0)
printf("ERROR: %d is not found.\n" ,a);
else if (pos_in.count(b) == 0 )
printf("ERROR: %d is not found.\n" , b);
else
lca(in,pre,0, num_nodes - 1, 0, pos_in[a], pos_in[b]);
}
}