题目

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

1
2
3
4
5
6
7
8
6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

1
2
3
4
5
6
LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题解

思路

  • 题目给定了一棵二叉搜索树,然后给你两个节点,求它们的最近的公共上级
  • 给定的树是以中序遍历的形式给出的
  • 这个中序遍历和二叉搜索树是重点
  • 因为是前序遍历,就是根左右,所以根的大小就在左右大小之间。
  • 所以我们只要遍历前序遍历,找到第一个在两个节点中间的点,便是它们的公共上级。

数据结构

  • pre 是前序遍历
  • sets 是所有节点的集合

算法

  • 先判断u和v是不是在节点中
  • 然后遍历前序遍历
  • 当找到了一个在两个节点大小中间的节点的时候,它就是根。

代码

  • Python会有一个点超时。放了C++和Python的题解。

Python

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
num_test, num_nodes = list(map(int, input().split()))
pre = list(map(int, input().split()))
sets = set(pre)
for i in range(num_test):
u, v = list(map(int, input().split()))
if u not in sets and v not in sets:
print("ERROR: %d and %d are not found." % (u, v))
elif u not in sets:
print("ERROR: %d is not found." % u)
elif v not in sets:
print("ERROR: %d is not found." % v)
else:
for j in pre:
if u <= j <= v or v <= j <= u:
if j == u:
print("%d is an ancestor of %d." % (u, v))
elif j == v:
print("%d is an ancestor of %d." % (v, u))
else:
print("LCA of %d and %d is %d." % (u, v, j))
break

C++

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
#include <bits/stdc++.h>

using namespace std;

int main() {
int num_tests, num_nodes;
cin >> num_tests >> num_nodes;
int pre[num_nodes];
unordered_set<int> sets;
for (int i = 0; i < num_nodes; i++) {
cin >> pre[i];
sets.insert(pre[i]);
}
for (int i = 0; i < num_tests; i++) {
int u, v;
cin >> u >> v;
if (sets.count(u) == 0 and sets.count(v) == 0)
printf("ERROR: %d and %d are not found.\n", u, v);
else if (sets.count(u) == 0)
printf("ERROR: %d is not found.\n", u);
else if (sets.count(v) == 0)
printf("ERROR: %d is not found.\n", v);
else {
for (auto it:pre) {
if ((it >= u && it <= v) || (it >= v && it <= u)) {
if (it == u)
printf("%d is an ancestor of %d.\n", u, v);
else if (it == v)
printf("%d is an ancestor of %d.\n", v, u);
else
printf("LCA of %d and %d is %d.\n", u, v, it);
break;
}
}
}
}
}