题目

Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A1 and A2 of n1 and n2 numbers, respectively. Let S1 and S2 denote the sums of all the numbers in A1 and A2, respectively. You are supposed to make the partition so that ∣n1−n2∣ is minimized first, and then ∣S1−S2∣ is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N(2N105)N (2≤N≤10^5), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 2312^{31}.

Output Specification:

For each case, print in a line two numbers: ∣n1−n2∣ and ∣S1−S2∣, separated by exactly one space.

Sample Input 1:

1
2
10
23 8 10 99 46 2333 46 1 666 555

Sample Output 1:

1
0 3611

Sample Input 2:

1
2
13
110 79 218 69 3721 100 29 135 2 6 13 5188 85

Sample Output 2:

1
1 9359

题解

思路

  • 憨憨题
  • 给你一个数列,让你尽可能等半分成两类,然后尽可能两类的差最大
  • 那么我们排序,大的一半分一类,少的分一类,分不均的归大的。
  • 输出即可

数据结构

  • nums 原数序列

算法

  • 排序
  • 做差
  • 输出

代码

  • 由于使用Python3能AC,因此只放了Python的题解。
1
2
3
n = int(input())
nums = sorted(list(map(int, input().split())), reverse=True)
print(n % 2, sum(nums[:(n + 1) // 2]) - sum(nums[((n + 1) // 2):]))