题目
Consider a positive integer N written in standard notation with k+1 digits as with for all i and . Then N is palindromic if and only if for all . Zero is written 0 and is also palindromic by definition.
Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )
Given any positive integer, you are supposed to find its paired palindromic number.
Input Specification:
Each input file contains one test case which gives a positive integer no more than 1000 digits.
Output Specification:
For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:
1 | A + B = C |
where A
is the original number, B
is the reversed A
, and C
is their sum. A
starts being the input number, and this process ends until C
becomes a palindromic number – in this case we print in the last line C is a palindromic number.
; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations.
instead.
Sample Input 1:
1 | 97152 |
Sample Output 1:
1 | 97152 + 25179 = 122331 |
Sample Input 2:
1 | 196 |
Sample Output 2:
1 | 196 + 691 = 887 |
题解
思路
- 照着要求反转字符串就行了
- 注意输出要以字符串的形式
- 不然前面的0会被忽略掉
数据结构
- 没啥数据结构
算法
- 开始十次遍历
- 每次遍历前把字符串反转一下
- 如果反转后和原字符串是相等的
- 输出相等的那段文字并break
- 否则,求它们俩的和
- 输出
- 使原数等于刚刚的和的字符串的表示
- 十次都没有则输出没找到。
代码
- 由于使用Python可以ac,因此只放了Python的解。
1 | a = input() |