题目
If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut
(Galleon
is an integer in , Sickle
is an integer in , and Knut
is an integer in [0, 29)).
Input Specification:
Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:
1 | 3.2.1 10.16.27 |
Sample Output:
1 | 14.1.28 |
题解
思路
- 就简单的加法
- 处理一下进位
- 完事儿
数据结构
- A,B是原数
- S是新数
算法
- 先加
- 再计算进位。
代码
- 因为使用Python能ac,因此只放了Python的代码。
1 | A, B = list(map(lambda x: x.split("."), input().split())) |